<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
		<meta name="robots" content="noodp,noydir" />
		<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Cutthroat Island: Film Review</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Suburban Times &raquo; Feed" href="https://thesubtimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Suburban Times &raquo; Comments Feed" href="https://thesubtimes.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Suburban Times &raquo; Cutthroat Island: Film Review Comments Feed" href="https://thesubtimes.com/2019/03/19/cutthroat-island-film-review/feed/" />
<link rel="canonical" href="https://thesubtimes.com/2019/03/19/cutthroat-island-film-review/" />
<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ --><script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><link rel='stylesheet' id='news-pro-theme-css'  href='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/themes/news-pro/style.css?ver=3.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-includes/css/dist/block-library/style.min.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Raleway%3A400%2C700%7CPathway+Gothic+One&#038;ver=3.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.1.1' type='text/css' media='all' />
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20190204'></script>
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.js?ver=1.13.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_pro_visitor_conditions = {"referrer_cookie_name":"advanced_ads_pro_visitor_referrer","referrer_exdays":"365","page_impr_cookie_name":"advanced_ads_page_impressions","page_impr_exdays":"3650"};
/* ]]> */
</script>
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.min.js?ver=2.3.3'></script>
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/advanced-ads-pro/modules/click-fraud-protection/assets/js/cfp.min.js?ver=2.3.3'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/themes/news-pro/js/responsive-menu.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/themes/news-pro/js/st_custom.js?ver=3.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/thesubtimes.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js?ver=2.3.3'></script>
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=7.1.1'></script>
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=7.1.1'></script>
<link rel='https://api.w.org/' href='https://thesubtimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thesubtimes.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="https://thesubtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthesubtimes.com%2F2019%2F03%2F19%2Fcutthroat-island-film-review%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thesubtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthesubtimes.com%2F2019%2F03%2F19%2Fcutthroat-island-film-review%2F&#038;format=xml" />
<script type="text/javascript">
		;var advadsCfpQueue = [], advadsCfpExpHours = 3;
		var advadsCfpClickLimit = 3;
		;
		var advadsCfpPath = '';
		var advadsCfpDomain = '';
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel="icon" href="https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/themes/news-pro/images/favicon.ico" />
<style type="text/css">.site-title a { background: url(https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/uploads/2014/02/TST_Logo_New.jpg) no-repeat !important; }</style>
		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
				<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Cutthroat Island: Film Review" />
<meta property="og:url" content="https://thesubtimes.com/2019/03/19/cutthroat-island-film-review/" />
<meta property="og:description" content="Whatever happened to pirate movies? There was a time when pirate movies were everywhere. From the 20’s to the 50’s, we got gems like The Black Pirate, Captain Blood, The Black Swan and The Sea Houn…" />
<meta property="article:published_time" content="2019-03-19T22:08:07+00:00" />
<meta property="article:modified_time" content="2019-02-27T19:13:25+00:00" />
<meta property="og:site_name" content="The Suburban Times" />
<meta property="og:image" content="https://i1.wp.com/thesubtimes.com/wp-content/uploads/2019/02/image-1.jpeg?fit=630%2C1200&amp;ssl=1" />
<meta property="og:image:width" content="630" />
<meta property="og:image:height" content="1200" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@thesubtimes" />
<meta name="twitter:site" content="@thesubtimes" />
<meta name="twitter:text:title" content="Cutthroat Island: Film Review" />
<meta name="twitter:image" content="https://i1.wp.com/thesubtimes.com/wp-content/uploads/2019/02/image-1.jpeg?fit=630%2C1200&#038;ssl=1&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
</head>
<body class="post-template-default single single-post postid-87313 single-format-standard custom-background custom-header header-image content-sidebar" itemscope itemtype="https://schema.org/WebPage"><!-- Google Tag Manager --><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-MSSTLQ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-MSSTLQ');</script><!-- End Google Tag Manager --><div class="site-container"><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://thesubtimes.com/">The Suburban Times</a></p><p class="site-description" itemprop="description">A community bulletin board for Western Pierce County.</p></div><div class="widget-area header-widget-area"><section id="advads_ad_widget-2" class="widget advads-widget"><div class="widget-wrap"><div style="text-align: center; " id="advads-2135660186"><a data-bid="1" href="https://thesubtimes.com/linkout/86110" rel="nofollow" target="_blank"><img width="728" height="90" src='https://i0.wp.com/thesubtimes.com/wp-content/uploads/2019/01/TPU-EO_201902_B.jpg?fit=728%2C90&ssl=1' alt='Tacoma Power Evergreen Options'  style="display: inline-block;"/></a></div></div></section>
</div></div></header><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-communities" class="menu genesis-nav-menu menu-primary"><li id="menu-item-59858" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-59858"><a href="https://thesubtimes.com" itemprop="url"><span itemprop="name">Home</span></a></li>
<li id="menu-item-76935" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76935"><a href="https://thesubtimes.com/category/things-to-know/" itemprop="url"><span itemprop="name">To Know</span></a></li>
<li id="menu-item-76936" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76936"><a href="https://thesubtimes.com/category/things-to-do/" itemprop="url"><span itemprop="name">To Do</span></a></li>
<li id="menu-item-76937" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-76937"><a href="https://thesubtimes.com/category/things-to-ponder/" itemprop="url"><span itemprop="name">To Ponder</span></a></li>
<li id="menu-item-77922" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77922"><a href="https://thesubtimes.com/tag/obituary-notices/" itemprop="url"><span itemprop="name">Obituaries</span></a></li>
<li id="menu-item-53724" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-53724"><a href="https://thesubtimes.com/calendar/" itemprop="url"><span itemprop="name">Calendar</span></a>
<ul class="sub-menu">
	<li id="menu-item-70550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70550"><a href="https://thesubtimes.com/calendar/submit-an-event/" itemprop="url"><span itemprop="name">Submit an Event</span></a></li>
</ul>
</li>
<li id="menu-item-57737" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57737"><a href="https://thesubtimes.com/subscribe-2/" itemprop="url"><span itemprop="name">Subscribe</span></a></li>
<li id="menu-item-40441" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40441"><a href="https://thesubtimes.com/about/" itemprop="url"><span itemprop="name">Advertise</span></a></li>
<li id="menu-item-55978" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-55978"><a href="https://thesubtimes.com/hdi/" itemprop="url"><span itemprop="name">More</span></a>
<ul class="sub-menu">
	<li id="menu-item-40439" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40439"><a href="https://thesubtimes.com/contact-us/" itemprop="url"><span itemprop="name">Contact</span></a></li>
	<li id="menu-item-56725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56725"><a href="https://thesubtimes.com/got-a-story-to-share/" itemprop="url"><span itemprop="name">Share a Story</span></a></li>
	<li id="menu-item-70626" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70626"><a href="https://thesubtimes.com/calendar/submit-an-event/" itemprop="url"><span itemprop="name">Submit an Event</span></a></li>
	<li id="menu-item-72143" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72143"><a href="https://thesubtimes.com/hdi/see-email-archives/" itemprop="url"><span itemprop="name">See Email Archives</span></a></li>
</ul>
</li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-87313 post type-post status-publish format-standard has-post-thumbnail category-things-to-ponder entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Cutthroat Island: Film Review</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2019-03-19T15:08:07-07:00">March 19, 2019</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://thesubtimes.com/author/bmeadowcroft/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Blake Meadowcroft</span></a></span> <span class="entry-comments-link"><a href="https://thesubtimes.com/2019/03/19/cutthroat-island-film-review/#comments">1 Comment</a></span> </p></header><div class="entry-content" itemprop="text">
<p>Whatever happened to pirate movies? There was a time when pirate movies were everywhere. From the 20’s to the 50’s, we got gems like <em>The Black Pirate</em>, <em>Captain Blood</em>, <em>The Black Swan</em> and <em>The Sea Hound</em>. Not only have these films been well received, but there was a lot of money, star power and effort put into these films. </p>



<span id="more-87313"></span>



<figure class="wp-block-image"><img src="https://i1.wp.com/thesubtimes.com/wp-content/uploads/2019/02/image-1.jpeg?ssl=1" alt data-recalc-dims="1" data-lazy-src="https://i1.wp.com/thesubtimes.com/wp-content/uploads/2019/02/image-1.jpeg?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i1.wp.com/thesubtimes.com/wp-content/uploads/2019/02/image-1.jpeg?ssl=1" alt="" data-recalc-dims="1"/></noscript><figcaption><em>Cutthroat Island (1995). </em>Image Source: <a href="http://imdb.com/">IMDB.com</a></figcaption></figure>



<p>You had big name actors like Douglas Fairbanks, Errol Flynn, Tyrone Power and Buster Crabb among many other stars of the time associated with these productions, and the public couldn’t get enough of them. They were practically the comic book movies of the early 20th century. But then the 60’s and 70’s rolled around. Pirate movies came out less frequently compared to the preceding decades, they started making less money, and everyone collectively decided to hang up their eyepatches, peg legs and talking parrots and call it a day. The pirate genre has been practically dead for the last couple of decades, sans the occasional miniseries or forgettable film. There have been attempts to revitalize the genre on multiple occasions. The most obvious example is <em>Pirates of the Caribbean: Curse of the Black Pearl</em>, which was a risky financial gambit for Disney that did manage to give the genre a kick in the pants for a short while. But the genre was once again sunk into the seas of mediocrity and irrelevance once the 4th sequel hit, it was once again put on life support. The other attempt at pirate relevancy came out 8 years before <em>Curse of the Black Pearl</em>, and is the movie I’m talking about today, <em>Cutthroat Island.</em> But unlike <em>Pirates of the Caribbean</em>, <em>Cutthroat Island </em>failed spectacularly. It failed to bring pirates back to the forefront of cinema, killed the careers of Geena Davis and Matthew Modine, bombed at the box office and squashed any hope of the pirate movie making money in Hollywood until Disney took a crack at it. It’s not a great movie, is what I’m getting at.</p>



<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-4-3 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<iframe width="500" height="375" src="https://www.youtube.com/embed/IV5JD490ZL4?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
</div></figure>



<p>	The movie takes place in Jamaica in 1668, and is about a tough pirate lady named Morgan Adams (Geena Davis), who is searching for the lost treasure of Cutthroat Island, which was buried there by her legendary pirate grandfather. The map to the island is spilt into 3 pieces, one of them being tattooed on her dead father’s scalp, and the other 2 are in undisclosed locations. As Morgan searches for the maps and treasure with her pirate crew and latin speaking love interest William Shaw, (Matthew Modine), she is constantly tracked and thwarted by her evil uncle and pirate captain Dawg Morgan (Frank Langella) who is also looking for the treasure (I guess piracy runs in the family). The story from there is a bog standard pirate adventure, with swashbuckling action, romance, pirate bawdiness, a monkey sidekick and a climactic showdown between protagonist and antagonist in the name of fame and fortune. It is a film that offers everything and yet nothing.</p>



<p>	<em>Cutthroat Island</em>’s agenda is very clear: To deliver a rip roaring pirate adventure reminiscent of the films from the golden age of cinema. An admirable goal, but not one that can be easily achieved as the film thinks. Everything about the film that makes up the pirate aesthetic feels either half baked or excessive. Take its humor for example. Pirate movies normally have a sly wit mixed with suggestive sexual innuendo in their dialogue. <em>Cutthroat Island</em> certainly has that, but the payoff to most of its jokes feel unfinished or clumsy. The first scene of the movie has Morgan at gunpoint by a soldier who she recently slept with. She coyly responds with “That won’t work. See, I took your balls.” And the musket balls from his gun are given to her by her monkey sidekick King George. The setup for the joke is okay, but the punch line is a bit awkward. Didn’t the monkey technically take his balls? Most of the movie’s jokes and innuendos are like that or even worse, and watching the film get so close to good comedic timing and constantly coming up short is frustrating. </p>



<p>	I will admit that the production value for the film is quite lucrative and put to good use. With $98 million attached, it better be. There are some great shots of ships and islands, some pretty decent sets and there was clearly a lot of effort put into the action and stunts. Perhaps too much effort. The stunts feel overly produced and ridiculous on multiple occasions. The film is clearly paying homage to the wonderful stunt work of stars like Errol Flynn by going all out with the special effects and stunts. But Errol Flynn’s stunts are grounded in reality compared to some of the stunts in <em>Cutthroat Island</em>. The two main leads drop through multiple wooden panels from a 3 story building, crash through a series of windows and top it off with a forward somersault onto a moving cart below, get pulled off a balcony with a chain around their neck back first onto a wooden table and fall off a 50 foot cliff into rocky waters. And they always just get up and walk it off, with only a few scratches. Wile E. Coyote would need to sit down and take a breather after some of these stunts! The movie is constantly trying to impress you with how good everything looks and how well produced the stunts are, but all it’s doing is throwing the audiences suspension of disbelief out the window. Why should I worry about these characters and be invested in the action if they can just walk off grievous bodily injury like this? Bullets and swords can clearly pierce their flesh, but I’m surprised that they don’t ricochet off their skin like Superman.</p>



<p>	I think one of the biggest disappointments about the movie is how much potential it had, but was ultimately wasted. It was the purest pirate flick we had in years and the opportunity to let loose and have fun with it was ripe. But all of the actors look like they’re showing up for a paycheck. The film had a great concept to play with, namely having a pirate movie with a leading lady as opposed to a man, a rarity in the genre, but nothing is done with it that puts the genre on its head. You could replace Geena Davis’ character with a male and I don’t think you’d have to change any major plot points, outside of some sex jokes and lines between Matthew Modine’s character, whose romantic relationship with Davis consists of the typical lusty snark we’ve all seen before in much better pirate movies. <em>Cuththroat Island </em>is just a below average pirate movie, and given the lavish budget and genre it’s associated with, that’s a real shame.	Normally, we would put a movie like this at the back of our minds forever and move on, but the damage it did at the box office is still felt to this day. Adjusted for inflation, it lost about $147 million, eradicated its production company Carolco Pictures and became Exhibit A on why pirate movies are box office poison. I believe that last point to be untrue. I believe every genre has a chance to shine and resurface if given the right push. I love pirate movies, and I think that there is still a potential market for it. <em>Pirates of the Caribbean </em>proved that (for a while anyway). I think the main problem is Hollywood. They blame the audience for shifting public opinion on a genre, but they fail to recognize that perhaps the audience opinions wouldn’t sway if the movies were better. “Nope. <em>Cutthroat Island </em>did terribly, therefore nobody wants to see pirate movies! It couldn’t possibly be the movie’s fault!” Flawless logic. True, <em>Cutthroat Island </em>didn’t do the pirate movie genre any favors, but neither has Hollywood. Will pirate movies ever emerge from the briny depths of Davy Jones’s locker to entertain us like they used to? I hope so. Let’s just nix Johnny Depp and his Keith Richards schtick, okay? That milk carton has long since passed its expiration date. </p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-87313" class="share-facebook sd-button share-icon no-text" href="https://thesubtimes.com/2019/03/19/cutthroat-island-film-review/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-87313" class="share-linkedin sd-button share-icon no-text" href="https://thesubtimes.com/2019/03/19/cutthroat-island-film-review/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-87313" class="share-twitter sd-button share-icon no-text" href="https://thesubtimes.com/2019/03/19/cutthroat-island-film-review/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://thesubtimes.com/2019/03/19/cutthroat-island-film-review/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://thesubtimes.com/2019/03/19/cutthroat-island-film-review/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-87313" class="share-pinterest sd-button share-icon no-text" href="https://thesubtimes.com/2019/03/19/cutthroat-island-film-review/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://thesubtimes.com/2019/03/19/cutthroat-island-film-review/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://thesubtimes.com/2019/03/19/cutthroat-island-film-review/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://thesubtimes.com/2019/03/19/cutthroat-island-film-review/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><div id="advads-21894171831"><div class="advads-content-middle" style="text-align: center; " id="advads-676154462"><div style="text-align: center; " id="advads-1028236944"><a data-bid="1" href="https://thesubtimes.com/linkout/65123" rel="nofollow" target="_blank"><img width="300" height="100" src="https://i0.wp.com/thesubtimes.com/wp-content/uploads/2015/10/Pierce-College-201707.jpg?fit=300%2C100&amp;ssl=1" alt="Pierce College" style="display: inline-block;" data-lazy-srcset="https://i0.wp.com/thesubtimes.com/wp-content/uploads/2015/10/Pierce-College-201707.jpg?w=300&amp;ssl=1 300w, https://i0.wp.com/thesubtimes.com/wp-content/uploads/2015/10/Pierce-College-201707.jpg?resize=125%2C42&amp;ssl=1 125w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i0.wp.com/thesubtimes.com/wp-content/uploads/2015/10/Pierce-College-201707.jpg?fit=300%2C100&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img width="300" height="100" src='https://i0.wp.com/thesubtimes.com/wp-content/uploads/2015/10/Pierce-College-201707.jpg?fit=300%2C100&ssl=1' alt='Pierce College'  srcset='https://i0.wp.com/thesubtimes.com/wp-content/uploads/2015/10/Pierce-College-201707.jpg?w=300&ssl=1 300w, https://i0.wp.com/thesubtimes.com/wp-content/uploads/2015/10/Pierce-College-201707.jpg?resize=125%2C42&ssl=1 125w' sizes='(max-width: 300px) 100vw, 300px' style="display: inline-block;"/></noscript></a></div></div></div><script>( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {var advads_content_p = jQuery("#advads-21894171831").parent().children("p:not(table p):not(blockquote p):not(div.wp-caption p)").filter(function(){return jQuery.trim(this.innerHTML)!==""});var advads_content_center_p = advads_content_p.eq( Math.round( ( advads_content_p.length - 3 ) / 2 ) );if( advads_content_center_p.length ) { advads.move("#advads-21894171831", advads_content_center_p, { method: "insertAfter" }); }});</script></div><footer class="entry-footer"><p class="entry-meta"></p></footer></article><section class="author-box" itemprop="author" itemscope itemtype="https://schema.org/Person"><h4 class="author-box-title">About <span itemprop="name">Blake Meadowcroft</span></h4><div class="author-box-content" itemprop="description"><p>Blake Meadowcroft was born and raised in Washington state and he’s too lazy to move to another one. He graduated from Charles Wright Academy in 2014, and then Central Washington University in 2018 majoring in Film and Video Studies with an emphasis in critical studies. He was a DJ for two years at 88.1 The ‘Burg, his college radio station, and has some experience in stand up comedy. </p>
<p>In layman’s terms, he’s really good at watching movies and saying if they’re good or not. His parents didn’t really put a cap on how many or what kind of movies he was allowed to watch when he was growing up, so he kind of……went crazy. He is passionate about film history and filmmaking, and approaches his reviews with both a critical mind and a witty sense of humor. He doesn’t like to pick favorites in terms of genre (although if you were to twist his arm, he’d probably go with fantasy). He’s willing to give any kind of movie a chance and doesn’t judge it based on what kind of film it is, but how well it’s made.</p>
<p>Blake has volunteered and interned for multiple film festivals including the Ellensburg, Gig Harbor, and Tacoma film festivals. He lives in Lakewood, and is currently a film critic for Lakeside Living Magazine.</p>
</div></section><div class="entry-comments" id="comments"><h3>Comments</h3><ol class="comment-list">
	<li class="comment even thread-even depth-1" id="comment-112296">
	<article itemprop="comment" itemscope itemtype="https://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="https://schema.org/Person">
				<span itemprop="name">Chas. Ames</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2019-03-19T15:34:59-07:00" itemprop="datePublished"><a href="https://thesubtimes.com/2019/03/19/cutthroat-island-film-review/#comment-112296" class="comment-time-link" itemprop="url">March 19, 2019 at 3:34 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>I&#8217;m predisposed to like anything Geena Davis is in, although she hasn&#8217;t been in anything successful since Long Kiss Goodnight, in my opinion.  But her catalog stands as quirky and engaging; good enough for me.</p>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='/2019/03/19/cutthroat-island-film-review/?replytocom=112296#respond' data-commentid="112296" data-postid="87313" data-belowelement="comment-112296" data-respondelement="respond" aria-label='Reply to Chas. Ames'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->
</ol></div>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/03/19/cutthroat-island-film-review/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://thesubtimes.com/wp-comments-post.php?wpe-comment-post=thesubtimes" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='87313' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="48f18dbd3a" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="116"/></p>			</form>
			</div><!-- #respond -->
	</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="https://thesubtimes.com/" role="search"><input class="search-form-input" type="search" itemprop="query-input" name="s" id="searchform-5c916f54c22e34.72407240" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta itemprop="target" content="https://thesubtimes.com/?s={s}"></form></div></section>
<section id="advads_ad_widget-13" class="widget advads-widget"><div class="widget-wrap"><div class="advads-sidebar-1" id="advads-1246248471"><div style="text-align: center; " id="advads-1928178201"><a data-bid="1" href="https://thesubtimes.com/linkout/65110" rel="nofollow" target="_blank"><img width="300" height="160" src='https://i0.wp.com/thesubtimes.com/wp-content/uploads/2015/10/brinksadler300x160.jpg?fit=300%2C160&ssl=1' alt=''  style="display: inline-block;"/></a></div></div></div></section>
<section id="custom_html-2" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><iframe src="https://www.google.com/calendar/embed?showNav=0&amp;showPrint=0&amp;showTabs=0&amp;showCalendars=0&amp;showTz=0&amp;mode=AGENDA&amp;height=600&amp;wkst=1&amp;bgcolor=%23FFFFFF&amp;src=thesubtimes.com_kphi7spnh4t0mmp11a0k1e5c9g%40group.calendar.google.com&amp;color=%23A32929&amp;ctz=America%2FLos_Angeles" style=" border-width:0 " width="300" height="600" frameborder="0" scrolling="no"></iframe></div></div></section>
<section id="advads_ad_widget-14" class="widget advads-widget"><div class="widget-wrap"><div class="advads-sidebar-2" id="advads-524970530"><div style="text-align: center; " id="advads-864155276"><a data-bid="1" href="https://thesubtimes.com/linkout/74719" rel="nofollow" target="_blank"><img width="300" height="160" src='https://i2.wp.com/thesubtimes.com/wp-content/uploads/2017/06/Saint-Frances-Cabrini-2018-19.jpg?fit=300%2C160&ssl=1' alt='Saint Frances Cabrini School'  style="display: inline-block;"/></a></div></div></div></section>
<section id="text-3" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><p><!-- Begin MailChimp Signup Form --></p>
<div id="mc_embed_signup">
<form id="mc-embedded-subscribe-form" class="validate" action="https://thesubtimes.us1.list-manage.com/subscribe/post?u=e3b4fba30149b1ec29f7fdb52&amp;id=4a8f53e3e2" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank">
<div id="mc_embed_signup_scroll">
<h2><font color="#ff3333">Become a better informed citizen.</font></h2>
<p>Join over <strong>24,000 readers</strong> each month and get real-local news and information direct to your inbox, Monday-Saturday.</p>
<div class="mc-field-group"><label for="mce-EMAIL">Email Address </label><br />
<input id="mce-EMAIL" class="required email" name="EMAIL" type="email" value="" /></div>
<div id="mce-responses" class="clear">
<div id="mce-error-response" class="response" style="display: none;"></div>
<div id="mce-success-response" class="response" style="display: none;"></div>
</div>
<p><!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups--></p>
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_e3b4fba30149b1ec29f7fdb52_4a8f53e3e2" type="text" value="" /></div>
<div class="clear"><input id="mc-embedded-subscribe" class="button" name="subscribe" type="submit" value="Sign Up Now For Free!" /></div>
</div>
</form>
</div>
<p><!--End mc_embed_signup--></p>
</div>
		</div></section>
<section id="recent-comments-3" class="widget widget_recent_comments"><div class="widget-wrap"><h4 class="widget-title widgettitle">Recent Comments</h4>
<ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Chas. Ames</span> on <a href="https://thesubtimes.com/2019/03/19/cutthroat-island-film-review/comment-page-1/#comment-112296">Cutthroat Island: Film Review</a></li><li class="recentcomments"><span class="comment-author-link">Chas. Ames</span> on <a href="https://thesubtimes.com/2019/03/19/final-notice-and-public-review-proposed-activity-in-a-100-year-floodplain/comment-page-1/#comment-112295">Final notice and public review: Proposed activity in a 100-year floodplain</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.StephenNeufeld.com' rel='external nofollow' class='url'>Stephen</a></span> on <a href="https://thesubtimes.com/2019/03/18/letter-apparently-parenting-is-making-a-comeback/comment-page-1/#comment-112290">Letter: Apparently, parenting is making a comeback</a></li><li class="recentcomments"><span class="comment-author-link">kenneth</span> on <a href="https://thesubtimes.com/2019/03/16/cvn-helps-veterans-and-military-families-improve-sleep-habits-and-their-mental-health/comment-page-1/#comment-112286">CVN Helps Veterans and Military Families Improve Sleep Habits and Their Mental Health</a></li><li class="recentcomments"><span class="comment-author-link">Suzanne Merriam</span> on <a href="https://thesubtimes.com/2019/03/15/letter-the-wisdom-of-treating-waughop-lake-with-alum-needs-to-be-questioned/comment-page-1/#comment-112283">Letter: The wisdom of treating Waughop Lake with alum needs to be questioned</a></li></ul></div></section>
<section id="text-2" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Contact Us</h4>
			<div class="textwidget"><p>The Suburban Times<br />
P.O. Box 39099<br />
Lakewood, WA 98496</p>
<p><a href="mailto:ben@thesubtimes.com">Ben Sclair</a>, Publisher<br />
253-312-1804</p>
<p><a href="mailto:stephen@thesubtimes.com">Stephen Neufeld</a>, Marketing Executive<br />
253-318-7013</p>
</div>
		</div></section>
</aside></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2019 The Suburban Times • <a href="https://thesubtimes.com/wp-login.php">Log in</a> • <a href="/privacy-policy/">Privacy Policy</a></p></div></footer></div>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/thesubtimes.com\/2019\/03\/19\/cutthroat-island-film-review\/":87313};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/2019/03/19/cutthroat-island-film-review/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201912'></script>
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-includes/js/comment-reply.min.js?ver=5.1.1'></script>
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/lazy-images/js/lazy-images.min.js?ver=7.1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advadsTracking = {"ajaxurl":"https:\/\/thesubtimes.com\/wp-admin\/admin-ajax.php?action=advanced-ads-tracking-track","method":"frontend","blogId":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/script.js?ver=1.8.15'></script>
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=7.1.1'></script>
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=5.1.1'></script>
<script async="async" type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=7.1.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script>window.advads_has_ads = [["86110","ad",null],["65123","ad",null],["65110","ad",null],["74719","ad",null]];

( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( window.advanced_ads_pro ) {advanced_ads_pro.process_passive_cb();} else if ( window.console && window.console.log ) {console.log('Advanced Ads Pro: cache-busting can not be initialized');} });</script><script type='text/javascript' src='https://stats.wp.com/e-201912.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.1.1',blog:'35196774',post:'87313',tz:'-7',srv:'thesubtimes.com'} ]);
	_stq.push([ 'clickTrackerInit', '35196774', '87313' ]);
</script>
<script type="text/javascript">var advads_tracking_ads = {"1":[86110,65123,65110,74719]};var advads_tracking_urls = {"1":"https:\/\/thesubtimes.com\/wp-admin\/admin-ajax.php?action=advanced-ads-tracking-track"};var advads_gatracking_uids = {"1":"UA-170680-1"};var advads_tracking_methods = {"1":"frontend"};var advads_tracking_parallel = {"1":false};var advads_tracking_linkbases = {"1":"https:\/\/thesubtimes.com\/linkout\/"};var advads_gatracking_allads = {"1":{"86750":{"title":"Baha'i Faith","target":"https:\/\/www.facebook.com\/upbahais\/"},"86110":{"title":"TPU","target":"www.MyTPU.org\/Evergreen?utm_source=The%20Suburban%20Times%202019&utm_medium=Web%20Banner&utm_campaign=Renewable%20Grants&utm_content=Renewable%20Grants"},"70459":{"title":"Charles Wright Academy","target":"https:\/\/www.charleswright.org\/admissions\/getting-started-2\/"},"84455":{"title":"Mark Lindquist","target":"https:\/\/marklindquist.org\/"},"82920":{"title":"Christine Kilduff","target":"http:\/\/www.christinekilduff.com\/"},"84419":{"title":"Little Church on the Prairie","target":"https:\/\/lcop.ws\/"},"70739":{"title":"Dick Muri","target":"https:\/\/dickmuri.com\/"},"83693":{"title":"Mari Leavitt","target":"http:\/\/marileavitt.com\/"},"83607":{"title":"Lakewood FAB Festival","target":"https:\/\/www.facebook.com\/lakewoodfilmartsbooks"},"71317":{"title":"Christ Lutheran Church","target":"http:\/\/christlutheranlakewood.com\/"},"65118":{"title":"Historic Ft. Steilacoom","target":"http:\/\/www.historicfortsteilacoom.org\/christmas.html"},"76855":{"title":"Ria Covington","target":"https:\/\/www.we4ria.com\/"},"72412":{"title":"Bates Technical College","target":"http:\/\/www.startatbates.me\/"},"75344":{"title":"Lakewood Asian Film Festival","target":"http:\/\/thesubtimes.com\/2017\/07\/31\/gripping-rabbit-proof-fence-indian-thriller-airlift-set-for-saturday-12-aug-at-lakewood-asian-film-fest\/"},"75331":{"title":"City of DuPont","target":"http:\/\/www.dupontwa.gov\/DocumentCenter\/View\/2014"},"74719":{"title":"St. Frances Cabrini","target":"https:\/\/www.cabrinischool.org\/"},"65113":{"title":"DuPont Museum","target":"http:\/\/www.dupontmuseum.com\/"},"73419":{"title":"Lakewood Rotary - Sportsmans Dinner 2017","target":"http:\/\/www.lakewoodrotary.com\/SitePage\/sportsmen-s-dinner"},"72602":{"title":"Mountain View Funeral Home","target":"http:\/\/www.mountainviewtacoma.com\/"},"70419":{"title":"Lakewold Gardens","target":"http:\/\/www.lakewoldgardens.org\/group_tours.html"},"67209":{"title":"Bridgeport Place","target":"http:\/\/www.bridgeportplaceassisted.com\/"},"66151":{"title":"Lakewood Historical Society","target":"http:\/\/www.lakewoodhistorical.org\/"},"65126":{"title":"Xfinity","target":"http:\/\/www.xfinity.com\/Corporate\/Learn\/Bundles\/bundles.html"},"65125":{"title":"Tacoma Community College","target":"https:\/\/www.tacomacc.edu\/tcc-life\/?utm_source=suburbantimes&utm_medium=banner"},"65123":{"title":"Pierce College","target":"http:\/\/www.pierce.ctc.edu\/"},"65119":{"title":"KLAY","target":"mailto:bobm@klay1180.com"},"65116":{"title":"Edward Jones","target":"https:\/\/www.edwardjones.com\/financial-advisor\/index.html?CIRN=DJmJq7CY0z0rqgPGJj3FuMEMK6X3LmGqxSZEGw5ca7YXCq8IG3zk8MeM%2Fv%2BM9oKi"},"65114":{"title":"Ed Selden Carpet One","target":"http:\/\/www.edseldencarpetone.com\/"},"65112":{"title":"Clover Park Technical College","target":"http:\/\/www.cptc.edu\/"},"65110":{"title":"Brink & Sadler","target":"http:\/\/www.brinkandsadler.com\/"},"65109":{"title":"Abbey Carpet","target":"http:\/\/tacoma.abbeycarpet.com\/"},"65108":{"title":"Click","target":"https:\/\/www.clickcabletv.com\/thehometeam\/?utm_source=Sub%20Times%20Group&utm_medium=Webbanner%20Digital&utm_campaign=The%20Home%20Team&utm_term=The%20Home%20Team&utm_content=The%20Home%20Team"}}};var advads_gatracking_anonym = true;</script></body></html>
