<!DOCTYPE html><html lang="en-US"><head ><meta charset="UTF-8" /><meta name="robots" content="noodp,noydir" /><meta name="viewport" content="width=device-width, initial-scale=1" /><link type="text/css" media="all" href="https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/cache/autoptimize/1/css/autoptimize_eae1f16fe6769a7aa22f4393b3e52c22.css" rel="stylesheet" /><title>Steilacoom Town Administrator March 30 Council Update</title><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="The Suburban Times &raquo; Feed" href="https://thesubtimes.com/feed/" /><link rel="alternate" type="application/rss+xml" title="The Suburban Times &raquo; Comments Feed" href="https://thesubtimes.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="The Suburban Times &raquo; Steilacoom Town Administrator March 30 Council Update Comments Feed" href="https://thesubtimes.com/2018/03/30/steilacoom-town-administrator-march-30-council-update/feed/" /><link rel="canonical" href="https://thesubtimes.com/2018/03/30/steilacoom-town-administrator-march-30-council-update/" /> <!--noptimize--><script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><!--/noptimize--><link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Raleway%3A400%2C700%7CPathway+Gothic+One&#038;ver=3.0.0' type='text/css' media='all' /> <script type='text/javascript'>var advanced_ads_pro_visitor_conditions = {"referrer_cookie_name":"advanced_ads_pro_visitor_referrer","referrer_exdays":"365","page_impr_cookie_name":"advanced_ads_page_impressions","page_impr_exdays":"3650"};</script> <!--[if lt IE 9]> <script type='text/javascript' src='https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script> <![endif]--><link rel='https://api.w.org/' href='https://thesubtimes.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thesubtimes.com/xmlrpc.php?rsd" /><link rel="alternate" type="application/json+oembed" href="https://thesubtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthesubtimes.com%2F2018%2F03%2F30%2Fsteilacoom-town-administrator-march-30-council-update%2F" /><link rel="alternate" type="text/xml+oembed" href="https://thesubtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthesubtimes.com%2F2018%2F03%2F30%2Fsteilacoom-town-administrator-march-30-council-update%2F&#038;format=xml" /> <script type="text/javascript">;var advadsCfpQueue = [], advadsCfpExpHours = 3;
		var advadsCfpClickLimit = 3;
		;
		var advadsCfpPath = '';
		var advadsCfpDomain = '';
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};</script> <link rel='dns-prefetch' href='//widgets.wp.com'/><link rel='dns-prefetch' href='//s0.wp.com'/><link rel='dns-prefetch' href='//0.gravatar.com'/><link rel='dns-prefetch' href='//1.gravatar.com'/><link rel='dns-prefetch' href='//2.gravatar.com'/><link rel="icon" href="https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/themes/news-pro/images/favicon.ico" /><meta property="og:type" content="article" /><meta property="og:title" content="Steilacoom Town Administrator March 30 Council Update" /><meta property="og:url" content="https://thesubtimes.com/2018/03/30/steilacoom-town-administrator-march-30-council-update/" /><meta property="og:description" content="Upcoming Meetings: Council Meeting – April 3, 2018, at 6:30 PM at Town Hall Planning Commission – April 9, 2018, at 6:30 PM at Town Hall. Preservation and Review Board – April 25, 2018, at 6:30 PM …" /><meta property="article:published_time" content="2018-03-31T04:08:37+00:00" /><meta property="article:modified_time" content="2018-03-31T03:56:59+00:00" /><meta property="og:site_name" content="The Suburban Times" /><meta property="og:image" content="https://s0.wp.com/i/blank.jpg" /><meta property="og:locale" content="en_US" /><meta name="twitter:site" content="@thesubtimes" /><meta name="twitter:text:title" content="Steilacoom Town Administrator March 30 Council Update" /><meta name="twitter:card" content="summary" /><meta name="twitter:creator" content="@thesubtimes" /></head><body class="post-template-default single single-post postid-80373 single-format-standard custom-background custom-header header-image content-sidebar" itemscope itemtype="https://schema.org/WebPage"><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-MSSTLQ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-MSSTLQ');</script><div class="site-container"><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://thesubtimes.com/">The Suburban Times</a></p><p class="site-description" itemprop="description">A community bulletin board for Western Pierce County.</p></div><div class="widget-area header-widget-area"></div></div></header><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-communities" class="menu genesis-nav-menu menu-primary"><li id="menu-item-59858" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-59858"><a href="https://thesubtimes.com" itemprop="url"><span itemprop="name">Home</span></a></li><li id="menu-item-76935" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-76935"><a href="https://thesubtimes.com/category/things-to-know/" itemprop="url"><span itemprop="name">Things To Know</span></a></li><li id="menu-item-76936" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76936"><a href="https://thesubtimes.com/category/things-to-do/" itemprop="url"><span itemprop="name">Things To Do</span></a></li><li id="menu-item-76937" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76937"><a href="https://thesubtimes.com/category/things-to-ponder/" itemprop="url"><span itemprop="name">Things To Ponder</span></a></li><li id="menu-item-77922" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77922"><a href="https://thesubtimes.com/tag/obituary-notices/" itemprop="url"><span itemprop="name">Obituaries</span></a></li><li id="menu-item-53724" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-53724"><a href="https://thesubtimes.com/calendar/" itemprop="url"><span itemprop="name">Calendar</span></a><ul class="sub-menu"><li id="menu-item-70550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70550"><a href="https://thesubtimes.com/calendar/submit-an-event/" itemprop="url"><span itemprop="name">Submit an Event</span></a></li></ul></li><li id="menu-item-57737" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57737"><a href="https://thesubtimes.com/subscribe-2/" itemprop="url"><span itemprop="name">Subscribe</span></a></li><li id="menu-item-55978" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-55978"><a href="https://thesubtimes.com/hdi/" itemprop="url"><span itemprop="name">More</span></a><ul class="sub-menu"><li id="menu-item-40441" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40441"><a href="https://thesubtimes.com/about/" itemprop="url"><span itemprop="name">Advertise</span></a></li><li id="menu-item-40439" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40439"><a href="https://thesubtimes.com/contact-us/" itemprop="url"><span itemprop="name">Contact</span></a></li><li id="menu-item-56725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56725"><a href="https://thesubtimes.com/got-a-story-to-share/" itemprop="url"><span itemprop="name">Share a Story</span></a></li><li id="menu-item-70626" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70626"><a href="https://thesubtimes.com/calendar/submit-an-event/" itemprop="url"><span itemprop="name">Submit an Event</span></a></li><li id="menu-item-72143" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72143"><a href="https://thesubtimes.com/hdi/see-email-archives/" itemprop="url"><span itemprop="name">See Email Archives</span></a></li></ul></li></ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-80373 post type-post status-publish format-standard category-things-to-know tag-government tag-steilacoom entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Steilacoom Town Administrator March 30 Council Update</h1><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2018-03-30T21:08:37+00:00">March 30, 2018</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://thesubtimes.com/author/paulloveless/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Paul Loveless</span></a></span> <span class="entry-comments-link"><a href="https://thesubtimes.com/2018/03/30/steilacoom-town-administrator-march-30-council-update/#respond">Leave a Comment</a></span></p></header><div class="entry-content" itemprop="text"><p>Upcoming Meetings:</p><ul><li>Council Meeting – April 3, 2018, at 6:30 PM at Town Hall</li><li>Planning Commission – April 9, 2018, at 6:30 PM at Town Hall.</li><li>Preservation and Review Board – April 25, 2018, at 6:30 PM at Town Hall.</li><li>Civil Service Commission – April 5, 2018, at 2:00 PM at the Community Center.</li></ul><p><span id="more-80373"></span></p><p>Council Future Agenda “Look-Ahead” Issues:</p><p>Copies of the Agenda and staff reports are available at all Town facilities once published. The Agenda and Council meeting minutes are posted to the Town’s official website.</p><p>Seasonal Workers:</p><p>The Town is currently advertising for seasonal workers for our Summer Camp program. The announcements are available at all Town buildings and on the Town’s official website.</p><p>Townwide Power Outage – April 2nd:</p><p>A Townwide power outage is scheduled for April 2nd from 7 AM to 5 PM to allow BPA to perform maintenance on their substation that feeds the Town. While the outage is occurring, Town staff will also be performing work which would also normally necessitate local outages.</p><p>Spring Clean-Up:</p><p>Spring Clean-up is April 21st and 22nd from 9 AM to 5 PM at the Public Works facility.</p><p>Public Safety:</p><p>DEA National Drug Take Back Day:</p><p>The Town will be participating in the DEA National Drug Take Back Day on Saturday, April 28, 2018. Our designated location is the Town’s Public Safety Building at 601 Main Street which will be open from 10 AM to 2 PM. No liquids or sharps please.</p><p>Gun Locks:</p><p>In partnership with Project Child Safe, the Department of Public Safety is providing gun locks to Town residents. One (1) lock per address may be obtained at Public Safety during normal business hours.</p><p>Safety and Security:</p><p>If you observe suspicious activity, please contact Public Safety &#8211; non-emergency number – (253) 798-4721 as soon as possible.</p><p>To anonymously report suspicious activity please email the Department at <a href="mailto:crimetips@ci.steilacoom.wa.us">crimetips@ci.steilacoom.wa.us</a></p><p>Public Works:</p><p>Streets and Storm:</p><p>Crew Emphasis:</p><p>The crew inspected storm water catch basins; inspected developments; and performed other system maintenance.</p><p>Electrical:</p><p>Crew Emphasis:</p><p>The crew continued preparing for the April 2nd Townwide power outage; installed a temporary power service in the Birch Hill Estates; pulled pump #2 at the Chambers lift station that was disabled due to a mop being flushed into the sewer lines; disconnected a power service for a panel change in the 600 block of Gove Street; pulled primary cable for the Tasanee developments; and performed other system’s maintenance.</p><p>Water/Sewer:</p><p>Crew Emphasis:</p><p>The crew continued generator maintenance at sewer lift stations in preparation for the Townwide power outage; continued working on the Water Use Efficiency report; assisted the Electric crew; pulled pump #2 at the Chambers lift station and removed a mop head; flushed the Tasanee project water lines; continued cleaning the lower yard in preparation for Spring Clean-up; and performed other system maintenance.</p><p>Parks, Buildings and Grounds:</p><p>Crew Emphasis:</p><p>The crew assisted by the Cedar Creek Work Crew continued working on the raingarden at the Community Center; mowed and performed grounds maintenance at Town Hall, Public Safety, Community Center, and Byrd Mill Park; met with two Eagle Scout candidates and started obtaining project supplies; and performed other buildings and grounds maintenance activities.</p><p>Other:</p><p>Pierce County Library Speaker Series:</p><p>Pierce County in partnership with the Steilacoom Historical Museum Association and the Town of Steilacoom continue their speaker series with the following presentations at the Steilacoom Community Center:</p><p>Entertaining the Troops in Wartime: The Early History of Armed Forces Radio</p><p>Fri., April 13 @ 2 p.m.</p><p>John Jensen, audio historian and former radio station broadcaster, shares stories and anecdotes from Hollywood’s war effort and shows examples of one of the most effective forms of communication that was used to entertain, educate and inform our men and women in uniform during World War II.</p><p>Children of War</p><p>Fri., May 11 @ 2 p.m.</p><p>Ursula Scott, a retired school counselor and former teacher born in Berlin after WWII, addresses a broad subject that applies to all regions and nations that have ever been at war. Ursula’s talk focuses on children fathered by Russian soldiers who were born in Germany after WWII. What happened to those children?</p><p>White Privilege: The Other Side of Racial Inequality</p><p>Fri., June 8 @ 2 p.m.</p><p>Sociology professor Teresa Ciabattari leads an interactive conversation that explores what white privilege is and provides tools for learning how to address it. Participants will gain knowledge and resources to foster inclusion and racial justice in their own communities.</p><p>Redistricting: Why It Matters:</p><p>The League of Women Voters of Tacoma-Pierce County in partnership with the Town is sponsoring a non-partisan discussion of the process to determine our voting districts and how it affects our voice in the democratic process. Thursday, April 19, 2018, 6 PM to 8 PM. Steilacoom Town Hall – 1717 Lafayette Street, Steilacoom, Washington 98388.</p><p>Parks Appreciation Day:</p><p>Save the Date to join the City of Lakewood and other volunteers on Saturday, April 28 from 9 a.m. to noon at Fort Steilacoom Park (8714 87th Ave SW): Volunteers and City staff will be restoring historic cemetery markers, planting flowers, painting &#8211; gate to lake, fence work at the dog park and doing restoration around the new Waughop Lake trail.</p><p>Facing Pierce County Homelessness: Creating HomeFULLness:</p><p>Saturday, April 28, 2018 – 10 AM to 4 PM – Tacoma Convention Center – 1500 Commerce, Tacoma, Washington. A free public forum designed to provide information to understand more about the coauses of homelessness; learn about alternatives to homelessness; learn how you can be part of the solution. For more information, visit <a href="http://www.tacomapiercelwv.org/Homelessness_Forum" class="external" rel="nofollow" target="_blank">www.tacomapiercelwv.org/Homelessness_Forum</a>.</p><p>Steilacoom Historical Museum Opening:</p><p>After a winter hiatus, the Steilacoom Historical Museum is opening for regular open hours on Saturday, March 31. On both Saturdays and Sundays the Museum will be open from 1:00 to 5:00, along with the Wagon Shop and the historic Nathaniel Orr Home.</p><p>A new permanent exhibit wall entitled Before the Town delves into the history of the area before the town really formed. Early explorations by Vancouver, Puget and Wilkes are highlighted, the Native Americans already living in the area are discussed and the formation of both Fort Nisqually and Fort Steilacoom are part of the exhibit.</p><p>Be sure to visit the lower level of the Museum to see this exhibit designed by Chris Erlich and members of the Museum.  Several local Native American artifacts on loan from Milt Davidson and a mid 19th Century telescope from Joan Curtis accompany articles from the SHMA collection to enhance the learning experience.</p><p>On temporary exhibit are House Paint Sample books from the early 1940’s. They illustrate popular colors for houses in that time period and were available for reference at the Bair Drug and Hardware Store at that time as the store sold paint too. Also temporarily on display are some new acquisitions.  Artifacts originally owned by Steilacoom Captain Warren Gove were recently donated to the Museum by a Gove’s great-great nephew, Allie Shelton. Gove was the first local steamboat captain on Puget Sound in the mid-1800’s.</p><p>Special handmade items of children’s clothing from the late 1800’s and 1920’s are also on display. They were worn by children from the Charles “Bub” Schwab family in Steilacoom, donated by Schwab family daughters Diane, Pam and Jenny. The Museum is happy to welcome these items in like-new condition to the museum’s vintage clothing collection. For more information please call 253-584-4133.</p><p>Pierce Conservation District – Rain Garden Workshop:</p><p>Rain Garden Workshop &#8211; May 2 – 6 PM – Steilacoom Community Center, 2301 Worthington Street, Steilacoom, Washington 98388. Free.</p><p>Kiwanis Club of Steilacoom 2018 Bike Rodeo:</p><p>The Kiwanis Club of Steilacoom invites local children to attend the &#8220;Bike Rodeo&#8221; May 6th at Saltar&#8217;s Elementary School, 10:00 a.m. to Noon.</p><p>Bikes will be inspected to ensure they are in a safe working condition or may need adjustments.  A Public Safety Officer will check bike helmets for proper fit and condition.  Each child will then proceed through six stations, such as signals, braking, dodging obstructions, looking back safely.  All biking children will then receive their &#8220;Bike Rodeo&#8221; safety certificate.</p><p>A limited number of bikes and helmets will be available if needed.</p><p>Steilacoom Garden Club Plant Sale:</p><p>The Steilacoom Garden Club will be holding their annual plant sale on Saturday, May 12th from 9AM to 5 PM in the court area across from the Bair Bistro on Lafayette Street.  They will have perennials, annuals, bulbs, shrubs, and vegetable/herb starts as well as decorative pots for Mother&#8217;s Day gifts.</p><p>Vendors include the ever popular Laur’s Shabby Chic, Barb’s Broken Heart Art and George’s Unique Birdhouses. Contact Barb at <a href="mailto:Barb@pski.org">Barb@pski.org</a> if you’re arena vendor who specializes in items that support “Reduce. Reuse.Recycle. Repurpose.”</p><p>Still looking for a few select vendors who create herbal products (like soap); keep bees or make things from bees’ wax; create baked goods or jellies using herbs; knit using natural, undyed wool; do chainsaw art.</p><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-80373" class="share-facebook sd-button share-icon no-text" href="https://thesubtimes.com/2018/03/30/steilacoom-town-administrator-march-30-council-update/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-80373" class="share-google-plus-1 sd-button share-icon no-text" href="https://thesubtimes.com/2018/03/30/steilacoom-town-administrator-march-30-council-update/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-80373" class="share-linkedin sd-button share-icon no-text" href="https://thesubtimes.com/2018/03/30/steilacoom-town-administrator-march-30-council-update/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-80373" class="share-twitter sd-button share-icon no-text" href="https://thesubtimes.com/2018/03/30/steilacoom-town-administrator-march-30-council-update/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="https://thesubtimes.com/2018/03/30/steilacoom-town-administrator-march-30-council-update/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text" href="https://thesubtimes.com/2018/03/30/steilacoom-town-administrator-march-30-council-update/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-80373" class="share-pinterest sd-button share-icon no-text" href="https://thesubtimes.com/2018/03/30/steilacoom-town-administrator-march-30-council-update/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://thesubtimes.com/2018/03/30/steilacoom-town-administrator-march-30-council-update/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://thesubtimes.com/2018/03/30/steilacoom-town-administrator-march-30-council-update/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://thesubtimes.com/2018/03/30/steilacoom-town-administrator-march-30-council-update/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div></div><footer class="entry-footer"></footer></article><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/03/30/steilacoom-town-administrator-march-30-council-update/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://thesubtimes.com/wp-comments-post.php?wpe-comment-post=thesubtimes" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='80373' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="64680e3225" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="158"/></p></form></div></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="https://thesubtimes.com/" role="search"><meta itemprop="target" content="https://thesubtimes.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search this website &#x2026;" /><input type="submit" value="Search"  /></form></div></section><section id="custom_html-2" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><iframe src="https://www.google.com/calendar/embed?showNav=0&amp;showPrint=0&amp;showTabs=0&amp;showCalendars=0&amp;showTz=0&amp;mode=AGENDA&amp;height=600&amp;wkst=1&amp;bgcolor=%23FFFFFF&amp;src=thesubtimes.com_kphi7spnh4t0mmp11a0k1e5c9g%40group.calendar.google.com&amp;color=%23A32929&amp;ctz=America%2FLos_Angeles" style=" border-width:0 " width="300" height="600" frameborder="0" scrolling="no"></iframe></div></div></section><section id="text-3" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><p></p><div id="mc_embed_signup"><form id="mc-embedded-subscribe-form" class="validate" action="https://thesubtimes.us1.list-manage.com/subscribe/post?u=e3b4fba30149b1ec29f7fdb52&amp;id=4a8f53e3e2" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank"><div id="mc_embed_signup_scroll"><h2>Be a better informed citizen.</h2><p>Join over <strong>16,000 readers</strong> each month and get real-local news and information direct to your inbox, Monday-Saturday.</p><div class="mc-field-group"><label for="mce-EMAIL">Email Address </label><br /> <input id="mce-EMAIL" class="required email" name="EMAIL" type="email" value="" /></div><div id="mce-responses" class="clear"><div id="mce-error-response" class="response" style="display: none;"></div><div id="mce-success-response" class="response" style="display: none;"></div></div><p></p><div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_e3b4fba30149b1ec29f7fdb52_4a8f53e3e2" type="text" value="" /></div><div class="clear"><input id="mc-embedded-subscribe" class="button" name="subscribe" type="submit" value="Subscribe" /></div></div></form></div><p></p></div></div></section><section id="recent-comments-3" class="widget widget_recent_comments"><div class="widget-wrap"><h4 class="widget-title widgettitle">Recent Comments</h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Tom Shaw</span> on <a href="https://thesubtimes.com/2018/03/29/westside-story-no-saloons-no-dispensaries/comment-page-1/#comment-106386">Westside Story &#8211; No Saloons &amp; No Dispensaries</a></li><li class="recentcomments"><span class="comment-author-link">Jerry</span> on <a href="https://thesubtimes.com/2018/03/29/westside-story-no-saloons-no-dispensaries/comment-page-1/#comment-106385">Westside Story &#8211; No Saloons &amp; No Dispensaries</a></li><li class="recentcomments"><span class="comment-author-link">Pat Flynn</span> on <a href="https://thesubtimes.com/2018/03/30/what-does-hacked-really-mean/comment-page-1/#comment-106384">What does hacked really mean?</a></li><li class="recentcomments"><span class="comment-author-link">Susanne Bacon</span> on <a href="https://thesubtimes.com/2018/03/30/what-does-hacked-really-mean/comment-page-1/#comment-106383">What does hacked really mean?</a></li><li class="recentcomments"><span class="comment-author-link">Mary Hammond</span> on <a href="https://thesubtimes.com/2018/03/29/westside-story-no-saloons-no-dispensaries/comment-page-1/#comment-106382">Westside Story &#8211; No Saloons &amp; No Dispensaries</a></li></ul></div></section><section id="text-2" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Contact Us</h4><div class="textwidget"><p>The Suburban Times<br /> P.O. Box 39099<br /> Lakewood, WA 98496</p><p><a href="mailto:ben@thesubtimes.com">Ben Sclair</a>, Publisher<br /> 253-312-1804</p><p><a href="mailto:stephen@thesubtimes.com">Stephen Neufeld</a>, Marketing Executive<br /> 253-318-7013</p></div></div></section></aside></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2018 · <a href="http://my.studiopress.com/themes/news/">News Pro Theme</a> On <a href="http://www.studiopress.com/">Genesis Framework</a> · <a href="https://wordpress.org/">WordPress</a> · <a href="https://thesubtimes.com/wp-login.php">Log in</a></p></div></footer></div> <script type="text/javascript">window.WPCOM_sharing_counts = {"https:\/\/thesubtimes.com\/2018\/03\/30\/steilacoom-town-administrator-march-30-council-update\/":80373};</script> <div id="sharing_email" style="display: none;"><form action="/2018/03/30/steilacoom-town-administrator-march-30-council-update/" method="post"> <label for="target_email">Send to Email Address</label> <input type="email" name="target_email" id="target_email" value="" /> <label for="source_name">Your Name</label> <input type="text" name="source_name" id="source_name" value="" /> <label for="source_email">Your Email Address</label> <input type="email" name="source_email" id="source_email" value="" /> <input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" /> <img style="float: right; display: none" class="loading" src="https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" /> <input type="submit" value="Send Email" class="sharing_send" /> <a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a><div class="errors errors-1" style="display: none;"> Post was not sent - check your email addresses!</div><div class="errors errors-2" style="display: none;"> Email check failed, please try again</div><div class="errors errors-3" style="display: none;"> Sorry, your blog cannot share posts by email.</div></form></div> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201813'></script> <script type='text/javascript'>var advadsTracking = {"ajaxurl":"https:\/\/thesubtimes.com\/wp-admin\/admin-ajax.php?action=advanced-ads-tracking-track","method":"frontend"};</script> <script type='text/javascript'>var sharing_js_options = {"lang":"en","counts":"1"};</script> <script type='text/javascript'>var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});</script> <script type='text/javascript' src='https://stats.wp.com/e-201813.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.9',blog:'35196774',post:'80373',tz:'-7',srv:'thesubtimes.com'} ]);
	_stq.push([ 'clickTrackerInit', '35196774', '80373' ]);</script> <script>var advads_tracking_ads = [];</script><script type="text/javascript" defer src="https://3appfy2q49wi2mhvvo2g5qhs1agf-wpengine.netdna-ssl.com/wp-content/cache/autoptimize/1/js/autoptimize_7d2cf55ad9d31915b2c753a11fd6dc09.js"></script></body></html>